Getting mypy warnings from prospector that I don't get on my PC

Hello,
in Codacy I’m getting lots of warnings from prospector (in particular, those warnings come from mypy) that I don’t get if I run prospector locally on my PC.
The prospector configuration is exactly the same (I set Codacy to get the configuration file from my project).

I noticed that I can reproduce the same warnings on my PC if I set prospector to ignore all the __init__.py files in the project. That being said, when I was playing around with Codacy at the very beginning, I actually set it to ignore those files (in Settings → Ignored files) but then I removed them all. However, it seems that it continues to ignore them even if I pushed some commits afterwards and the repo was re-analyzed.
How can I solve this?

Thanks

Hi @ebellocchia !

Can you please send me the link for one of the commits / files where you are getting those issues so I can dig into this?

Thanks!

Hello,
yes sure, this is the last one (I hope it’s the correct way to link it): bip_utils - Codacy - Commits
All the issues like “Name XXX is not defined (error)” are from mypy and shouldn’t be there.

Thanks

I tried running the same prospector version of Codacy (1.3.1) on my PC (I was running the last version before) and I don’t get those warnings as well.
The steps to reproduce this are:

  • Clone the repository
  • Run prospector . in the repo folder: there’ll be a bunch of warnings (around 20) but much less than Codacy
  • Add __init__.py to the ignore-patterns in the prospector.yaml file
  • Run again prospector . in the repo folder: you’ll get the same warnings of Codacy

Thanks